[PATCH 2/8] v3 Add new phys_index properties
dave at linux.vnet.ibm.com
Wed Jul 21 05:10:04 EST 2010
On Tue, 2010-07-20 at 08:24 -0500, Nathan Fontenot wrote:
> Update the 'phys_index' properties of a memory block to include a
> 'start_phys_index' which is the same as the current 'phys_index' property.
> This also adds an 'end_phys_index' property to indicate the id of the
> last section in th memory block.
> Patch updated to keep the name of the phys_index property instead of
> renaming it to start_phys_index.
KAME is right on this. We should keep the old one if at all possible.
The only other thing we might want to do is move 'phys_index' to
'start_phys_index', and make a new 'phys_index' that does a WARN_ONCE(),
gives a deprecated warning, then calls the new 'start_phys_index' code.
So, basically make the new, more clear name, but keep the old one for a
while and deprecate it. Maybe we could get away with removing it in ten
More information about the Linuxppc-dev