[PATCH] powerpc/mpc512x: Add gpio driver

Grant Likely grant.likely at secretlab.ca
Wed Feb 17 06:19:50 EST 2010


Hi Matthias.  Thanks for the patch.  Some comments below...

On Thu, Jan 28, 2010 at 6:48 AM, Matthias Fuchs
<matthias.fuchs at esd-electronics.com> wrote:
> Signed-off-by: Matthias Fuchs <matthias.fuchs at esd.eu>

Could use a commit log.  It is useful to give some details about what
this driver has been developed/tested on.

> ---
>  arch/powerpc/include/asm/mpc512x_gpio.h |   30 +++++
>  arch/powerpc/platforms/Kconfig          |    9 ++
>  arch/powerpc/sysdev/Makefile            |    1 +
>  arch/powerpc/sysdev/mpc512x_gpio.c      |  179 +++++++++++++++++++++++++++++++

Move mpc512x_gpio.c to the arch/powerpc/platforms/512x directory.
Also put the Kconfig changes in arch/powerpc/platform/512x/Kconfig.

>  4 files changed, 219 insertions(+), 0 deletions(-)
>  create mode 100644 arch/powerpc/include/asm/mpc512x_gpio.h
>  create mode 100644 arch/powerpc/sysdev/mpc512x_gpio.c
>
> diff --git a/arch/powerpc/include/asm/mpc512x_gpio.h b/arch/powerpc/include/asm/mpc512x_gpio.h
> new file mode 100644
> index 0000000..8b6922d
> --- /dev/null
> +++ b/arch/powerpc/include/asm/mpc512x_gpio.h
> @@ -0,0 +1,30 @@
> +/*
> + * Copyright (C) 2010 Matthias Fuchs <matthias.fuchs at esd.eu>, esd gmbh
> + *
> + * This program is free software; you can redistribute it and/or modify
> + * it under the terms of the GNU General Public License version 2
> + * as published by the Free Software Foundation.
> + *
> + * This program is distributed in the hope that it will be useful,
> + * but WITHOUT ANY WARRANTY; without even the implied warranty of
> + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
> + * GNU General Public License for more details.
> + *
> + * You should have received a copy of the GNU General Public License
> + * along with this program; if not, write to the Free Software
> + * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
> + */
> +#ifndef MPC512X_GPIO_H
> +#define MPC512X_GPIO_H
> +
> +struct mpc512x_gpio_regs {
> +       u32 gpdir;
> +       u32 gpodr;
> +       u32 gpdat;
> +       u32 gpier;
> +       u32 gpimr;
> +       u32 gpicr1;
> +       u32 gpicr2;
> +};

Currently this is only used by the GPIO driver.  Move the structure
definition into the .c file.

> +
> +#endif /* MPC512X_GPIO_H */
> diff --git a/arch/powerpc/sysdev/mpc512x_gpio.c b/arch/powerpc/sysdev/mpc512x_gpio.c
> new file mode 100644
> index 0000000..09f075b
> --- /dev/null
> +++ b/arch/powerpc/sysdev/mpc512x_gpio.c
> @@ -0,0 +1,179 @@
> +/*
> + * MPC512x gpio driver
> + *
> + * Copyright (c) 2010 Matthias Fuchs <matthias.fuchs at esd.eu>, esd gmbh
> + *
> + * derived from ppc4xx gpio driver
> + *
> + * Copyright (c) 2008 Harris Corporation
> + * Copyright (c) 2008 Sascha Hauer <s.hauer at pengutronix.de>, Pengutronix
> + * Copyright (c) MontaVista Software, Inc. 2008.
> + *
> + * Author: Steve Falco <sfalco at harris.com>
> + *
> + * This program is free software; you can redistribute it and/or modify
> + * it under the terms of the GNU General Public License version 2
> + * as published by the Free Software Foundation.
> + *
> + * This program is distributed in the hope that it will be useful,
> + * but WITHOUT ANY WARRANTY; without even the implied warranty of
> + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
> + * GNU General Public License for more details.
> + *
> + * You should have received a copy of the GNU General Public License
> + * along with this program; if not, write to the Free Software
> + * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
> + */
> +
> +#include <linux/kernel.h>
> +#include <linux/init.h>
> +#include <linux/spinlock.h>
> +#include <linux/io.h>
> +#include <linux/of.h>
> +#include <linux/of_gpio.h>
> +#include <linux/gpio.h>
> +#include <linux/types.h>
> +#include <asm/mpc512x_gpio.h>
> +
> +#define GPIO_MASK(gpio)                (0x80000000 >> (gpio))

For clarity, this local define should also be prefixed with MPC5121_
so it is not confused with core gpio code.

> +
> +struct mpc512x_chip {
> +       struct of_mm_gpio_chip mm_gc;
> +       spinlock_t lock;
> +};
> +
> +/*
> + * GPIO LIB API implementation for GPIOs
> + *
> + * There are a maximum of 32 gpios in each gpio controller.
> + */
> +static inline struct mpc512x_chip *
> +to_mpc512x_gpiochip(struct of_mm_gpio_chip *mm_gc)
> +{
> +       return container_of(mm_gc, struct mpc512x_chip, mm_gc);
> +}
> +
> +static int mpc512x_gpio_get(struct gpio_chip *gc, unsigned int gpio)
> +{
> +       struct of_mm_gpio_chip *mm_gc = to_of_mm_gpio_chip(gc);
> +       struct mpc512x_gpio_regs __iomem *regs = mm_gc->regs;
> +
> +       return in_be32(&regs->gpdat) & GPIO_MASK(gpio);
> +}
> +
> +static inline void
> +__mpc512x_gpio_set(struct gpio_chip *gc, unsigned int gpio, int val)
> +{
> +       struct of_mm_gpio_chip *mm_gc = to_of_mm_gpio_chip(gc);
> +       struct mpc512x_gpio_regs __iomem *regs = mm_gc->regs;
> +
> +       if (val)
> +               setbits32(&regs->gpdat, GPIO_MASK(gpio));
> +       else
> +               clrbits32(&regs->gpdat, GPIO_MASK(gpio));

Rather than the read/modify/write cycle you're using here, you should
consider maintaining a shadow register for the GPIO output register.
Even though it is the SoC local bus, bus cycles can be expensive when
a shadow reg may already be in the cache.

Also, this may be a bug.  If you read the data register, modify just
the bit you care about and then write it back, then you are also
setting the output state of pins currently marked for input.  That
doesn't sound bad, but some drivers change the output state by
switching back and forth between input and output mode.  Using a
read/modify/write on the data register will break it.

> +}
> +
> +static void
> +mpc512x_gpio_set(struct gpio_chip *gc, unsigned int gpio, int val)
> +{
> +       struct of_mm_gpio_chip *mm_gc = to_of_mm_gpio_chip(gc);
> +       struct mpc512x_chip *chip = to_mpc512x_gpiochip(mm_gc);
> +       unsigned long flags;
> +
> +       spin_lock_irqsave(&chip->lock, flags);
> +
> +       __mpc512x_gpio_set(gc, gpio, val);
> +
> +       spin_unlock_irqrestore(&chip->lock, flags);
> +
> +       pr_debug("%s: gpio: %d val: %d\n", __func__, gpio, val);
> +}
> +
> +static int mpc512x_gpio_dir_in(struct gpio_chip *gc, unsigned int gpio)
> +{
> +       struct of_mm_gpio_chip *mm_gc = to_of_mm_gpio_chip(gc);
> +       struct mpc512x_chip *chip = to_mpc512x_gpiochip(mm_gc);
> +       struct mpc512x_gpio_regs __iomem *regs = mm_gc->regs;
> +       unsigned long flags;
> +
> +       spin_lock_irqsave(&chip->lock, flags);
> +
> +       /* Disable open-drain function */
> +       clrbits32(&regs->gpodr, GPIO_MASK(gpio));
> +
> +       /* Float the pin */
> +       clrbits32(&regs->gpdir, GPIO_MASK(gpio));
> +
> +       spin_unlock_irqrestore(&chip->lock, flags);
> +
> +       return 0;
> +}
> +
> +static int
> +mpc512x_gpio_dir_out(struct gpio_chip *gc, unsigned int gpio, int val)
> +{
> +       struct of_mm_gpio_chip *mm_gc = to_of_mm_gpio_chip(gc);
> +       struct mpc512x_chip *chip = to_mpc512x_gpiochip(mm_gc);
> +       struct mpc512x_gpio_regs __iomem *regs = mm_gc->regs;
> +       unsigned long flags;
> +
> +       spin_lock_irqsave(&chip->lock, flags);
> +
> +       /* First set initial value */
> +       __mpc512x_gpio_set(gc, gpio, val);
> +
> +       /* Disable open-drain function */
> +       clrbits32(&regs->gpodr, GPIO_MASK(gpio));
> +
> +       /* Drive the pin */
> +       setbits32(&regs->gpdir, GPIO_MASK(gpio));
> +
> +       spin_unlock_irqrestore(&chip->lock, flags);
> +
> +       pr_debug("%s: gpio: %d val: %d\n", __func__, gpio, val);
> +
> +       return 0;
> +}
> +
> +static int __init mpc512x_add_gpiochips(void)
> +{
> +       struct device_node *np;
> +
> +       for_each_compatible_node(np, NULL, "fsl,mpc5121-gpio") {
> +               int ret;
> +               struct mpc512x_chip *mpc512x_gc;
> +               struct of_mm_gpio_chip *mm_gc;
> +               struct of_gpio_chip *of_gc;
> +               struct gpio_chip *gc;
> +
> +               mpc512x_gc = kzalloc(sizeof(*mpc512x_gc), GFP_KERNEL);
> +               if (!mpc512x_gc) {
> +                       ret = -ENOMEM;
> +                       goto err;
> +               }
> +
> +               spin_lock_init(&mpc512x_gc->lock);
> +
> +               mm_gc = &mpc512x_gc->mm_gc;
> +               of_gc = &mm_gc->of_gc;
> +               gc = &of_gc->gc;
> +
> +               gc->ngpio = 32;
> +               gc->direction_input = mpc512x_gpio_dir_in;
> +               gc->direction_output = mpc512x_gpio_dir_out;
> +               gc->get = mpc512x_gpio_get;
> +               gc->set = mpc512x_gpio_set;
> +
> +               ret = of_mm_gpiochip_add(np, mm_gc);
> +               if (ret)
> +                       goto err;
> +               continue;
> +err:
> +               pr_err("%s: registration failed with status %d\n",
> +                      np->full_name, ret);
> +               kfree(mpc512x_gc);
> +               /* try others anyway */
> +       }
> +       return 0;
> +}
> +arch_initcall(mpc512x_add_gpiochips);

Don't do this.  Either make this a proper of_platform device driver,
or call mpc512x_add_gpiochips() explicitly from the arch platform
setup code.  Otherwise, if the kernel is built for multiplatform, this
function will get executed regardless of the platform.

Cheers,
g.

-- 
Grant Likely, B.Sc., P.Eng.
Secret Lab Technologies Ltd.


More information about the Linuxppc-dev mailing list