[PATCH] [SCSI] mpt fusion: Fix 32 bit platforms with 64 bit resources
Benjamin Herrenschmidt
benh at kernel.crashing.org
Tue Sep 15 20:29:38 EST 2009
> diff --git a/drivers/message/fusion/mptbase.c b/drivers/message/fusion/mptbase.c
> index 5d496a9..d5b0f15 100644
> --- a/drivers/message/fusion/mptbase.c
> +++ b/drivers/message/fusion/mptbase.c
> @@ -1510,11 +1510,12 @@ static int
> mpt_mapresources(MPT_ADAPTER *ioc)
> {
> u8 __iomem *mem;
> + u8 __iomem *port;
> int ii;
> - unsigned long mem_phys;
> - unsigned long port;
> - u32 msize;
> - u32 psize;
> + phys_addr_t mem_phys;
> + phys_addr_t port_phys;
> + resource_size_t msize;
> + resource_size_t psize;
Is phys_addr_t defined for all archs nowadays ? Why not use
resource_size_t for everything ? resource_size_t is a bit of a misnomer,
it's not a type supposed to reference a "size" but really a physical
address (or a size)... it's been called resource_size_t I believe
because it's "sized" appropriately for holding a physical address.
Cheers,
Ben.
More information about the Linuxppc-dev
mailing list