c67x00 with mpc85xx

Grant Likely grant.likely at secretlab.ca
Tue Nov 10 06:23:05 EST 2009

On Fri, Oct 16, 2009 at 12:44 PM, Jeff Angielski <jeff at theptrgroup.com> wrote:
> We are using the Cypress USB Host (CY7C67300) with a Freescale MPC8544 and
> can only get it to work if we add a delay after writing to the hardware
> registers through the HPI.
> We tried playing with the SCY settings in the GPCM but nothing helps. It is
> only when we add usecs of delay after our write() functions that the
> hardware works.
> The datasheets make no mention of any write-then-read requirements and the
> FAEs are stumped right now.
> I was just hoping somebody had some experiencing interfacing this chip to
> the PowerPC and that they could offer some suggestions or ideas.

I've worked with the part attached to the ppc440 inside a Xilinx FPGA.
 Though I ran into many problems, I haven't seen the problem that you
describe.  Sorry.


Grant Likely, B.Sc., P.Eng.
Secret Lab Technologies Ltd.

More information about the Linuxppc-dev mailing list