[PATCH 1/2] powerpc/405ex: provide necessary fixup function to support cuImage
Josh Boyer
jwboyer at linux.vnet.ibm.com
Fri Aug 21 21:49:19 EST 2009
On Fri, Aug 21, 2009 at 02:00:20PM +0800, tiejun.chen wrote:
>as I know. So I prefer to prefix with ibm405ex as you suggestion.
>
>>> diff --git a/arch/powerpc/boot/dcr.h b/arch/powerpc/boot/dcr.h
>>> index 95b9f53..ba41624 100644
>>> --- a/arch/powerpc/boot/dcr.h
>>> +++ b/arch/powerpc/boot/dcr.h
>>> @@ -153,6 +153,18 @@ static const unsigned long sdram_bxcr[] = { SDRAM0_B0CR, SDRAM0_B1CR,
>>> #define DCRN_CPC0_PLLMR1 0xf4
>>> #define DCRN_CPC0_UCR 0xf5
>>>
>>> +/* 405EX Clocking Control regs */
>>> +#define CPR0_CLKUPD 0x0020
>>> +#define CPR0_PLLC 0x0040
>>> +#define CPR0_PLLD 0x0060
>>> +#define CPR0_CPUD 0x0080
>>> +#define CPR0_PLBD 0x00a0
>>> +#define CPR0_OPBD 0x00c0
>>> +#define CPR0_PERD 0x00e0
>>> +#define CPR0_AHBD 0x0100
>>> +#define CPR0_ICFG 0x0140
>>
>> You duplicated the #defines right below this. Just change the comment for
>> the already existing defines to say "440GX/405EX Clock Control regs".
>
>I want to isolate 405EX with other 4xx for convenient maintaining code as my
>original. And although there are same offset as the register of 440GX, they are
>defined with different name on manual because of different design mechanism. So
>I hope we cannot be confused these when others track the codes.
That would make sense if #defines were something that really needed a lot of
maintenance, but they aren't. They are essentially static once correct. I'd
prefer not to grow another set of duplicate #defines.
Thanks.
josh
More information about the Linuxppc-dev
mailing list