[PATCH 2/4] POWERPC: Move iommu dma ops from dma.c to dma-iommu.c

Becky Bruce becky.bruce at freescale.com
Sat Sep 13 01:32:54 EST 2008


On Sep 8, 2008, at 4:57 PM, Christoph Hellwig wrote:

> On Mon, Sep 08, 2008 at 02:09:53PM -0500, Becky Bruce wrote:
>> +/* We support DMA to/from any memory page via the iommu */
>> +static int dma_iommu_dma_supported(struct device *dev, u64 mask)
>> +{
>> +	struct iommu_table *tbl = dev->archdata.dma_data;
>> +
>> +	if (!tbl || tbl->it_offset > mask) {
>> +		printk(KERN_INFO
>> +		       "Warning: IOMMU offset too big for device mask\n");
>> +		if (tbl)
>> +			printk(KERN_INFO
>> +			       "mask: 0x%08lx, table offset: 0x%08lx\n",
>> +				mask, tbl->it_offset);
>> +		else
>> +			printk(KERN_INFO "mask: 0x%08lx, table unavailable\n",
>> +				mask);
>> +		return 0;
>> +	} else
>> +		return 1;
>> +}
>
> Small nitpick, but wouldn't a
>
> 	if (tbl && tbl->it_offset <= mask)
> 		return 1;
>
> 	< the rest>
>
> be much easier to read?

Seems cleaner to me..... but I want this patch, which is a move of the  
iommu code, to be *just* a move.  So I'm going to leave this as-is for  
now.

Thanks!
-Becky




More information about the Linuxppc-dev mailing list