[PATCH v2] [POWERPC] devres: Add devm_ioremap_flags()

Kumar Gala galak at kernel.crashing.org
Thu May 1 07:49:05 EST 2008

On Apr 30, 2008, at 4:42 PM, Benjamin Herrenschmidt wrote:
> On Wed, 2008-04-30 at 11:08 -0500, Kumar Gala wrote:
>> From: Emil Medve <Emilian.Medve at Freescale.com>
>> We provide an ioremap_flags so provide a coresphonding  
>> devm_ioremap_flags.
>> Signed-off-by: Emil Medve <Emilian.Medve at Freescale.com>
>> Signed-off-by: Kumar Gala <galak at kernel.crashing.org>
>> ---
>> Forgot to commit the actual implemtation in arch/powerpc/lib/devres.c
>> Which tree should this go through, powerpc.git?
> Let's call it ioremap_prot instead please. I'm about to change
> ioremap_flags to ioremap_prot anyways. Keep the flags/prot argument
> unsigned long for now (it can be argued it should be a pgprot but that
> hasn't been sorted out completely).

No problem.  I've always wondered why ioremap_* aren't better  
specified by generic code.

- k

More information about the Linuxppc-dev mailing list