[PATCH] Introduce ppc_pci_flags accessors

Josh Boyer jwboyer at linux.vnet.ibm.com
Thu Dec 11 11:53:13 EST 2008


On Wed, 10 Dec 2008 16:17:13 -0800 (PST)
Trent Piepho <tpiepho at freescale.com> wrote:

> On Wed, 10 Dec 2008, Josh Boyer wrote:
> > On Thu, 11 Dec 2008 10:46:28 +1100
> >>> +#ifdef CONFIG_PCI
> >>> +extern unsigned int ppc_pci_flags;
> >>> +#define ppc_pci_set_flags(flags) ppc_pci_flags = (flags)
> >>> +#define ppc_pci_add_flags(flags) ppc_pci_flags |= (flags)
> >>> +#define ppc_pci_flag_is_set(flag) (ppc_pci_flags & (flag))
> >>> +#else
> >>> +#define ppc_pci_set_flags(flags) do {} while (0)
> >>> +#define ppc_pci_add_flags(flags) do {} while (0)
> >>> +#define ppc_pci_flag_is_set(flag) (0)
> >>> +#endif
> >>
> >> I hate to be picky, but I don't see any reason why these shouldn't be
> >> static inlines.
> >
> > There's a perfectly good reason.  I AM LAZY.
> >
> > That aside, it doesn't matter to me either way.  If the general idea
> > seems fine and the naming of the functions is acceptable, I'd be happy
> > to respin.
> 
> If were allowed to be picky, I think ppc_pci_has_flag() is a better name
> than ppc_pci_flag_is_set().  Matches the other function names better, and a
> quick grep of the kernel source shows bar_has_foo() is much more common
> than bar_foo_is_set().

That's fine too.  I think you can Michael can have a virtual
arm-wrestling match to decide whether ppc_pci_has_flag or
ppc_pci_flags_are_set wins ;)

josh



More information about the Linuxppc-dev mailing list