Audio codec device tree entries
David Gibson
david at gibson.dropbear.id.au
Tue Oct 23 12:57:13 EST 2007
On Mon, Oct 22, 2007 at 09:59:00PM -0400, Jon Smirl wrote:
> Is this what the device tree entries should look like?
>
> First example is ac97 audio:
>
> ac97 at 2000 { // PSC1
> device_type = "sound";
Kill all these device_type values.
> compatible = "mpc5200b-psc-ac97\0mpc5200-psc-ac97";
dtc now supports the more readable:
compatible = "mpc5200b-psc-ac97", "mpc5200-psc-ac97";
Use it.
> cell-index = <0>;
cell-index should only be present if the device is within a
system-on-chip *and* that device number is used to program some global
register somewhere.
> reg = <2000 100>;
> interrupts = <2 1 0>;
> interrupt-parent = <&mpc5200_pic>;
> codec-handle = <&codec0>
> };
>
> pseudo-sound at 0 { // use to trigger loading platform specific fabric driver
> device_type = "pseudo-sound"
> };
This looks completely bogus. The device tree should represent actual
hardware.
> codec0:codec at 0 {
Space after the : please.
--
David Gibson | I'll have my music baroque, and my code
david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_
| _way_ _around_!
http://www.ozlabs.org/~dgibson
More information about the Linuxppc-dev
mailing list