[PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes
sshtylyov at ru.mvista.com
Wed Nov 28 05:07:14 EST 2007
Anton Vorontsov wrote:
>>>>>2. "ioport" because shift^Wstride ;-) applies only to the io range
>>>>>(yes, it's obvious, but worth open-wording, no?).
>>>> Contrarywise, to memory range.
>>>By io range I meant "I/O base", in contrast to "CTL base".
>>>There is no need to apply shifting for CTL. That's why ioport-*
>>>appeared in the first place.
>> So, a matter of wrong terminology then. The thing that you meant by
>> "I/O" is actually called "command block".
> Yes. And IO is the second name.
I'd say the first place in drivers/ide belongs to the historic name
"taskfile". The "command block" which is as ATA standard calls it, is hardly used.
> It's used widespread in the drivers/ide/.
Don't remember seeing it.
> Now you understand why I'm so reluctant to hanging up different
> labels on the single thing? ;-)
More information about the Linuxppc-dev