[PATCH] Split initrd logic out of early_init_dt_scan_chosen() to fix warning

Michael Ellerman michael at ellerman.id.au
Thu May 10 17:57:48 EST 2007


On Thu, 2007-05-10 at 09:48 +0200, Geert Uytterhoeven wrote:
> On Thu, 10 May 2007, Michael Ellerman wrote:
> > If CONFIG_BLK_DEV_INITRD is not defined the prop variable in
> > early_init_dt_scan_chosen() is unused, causing a compiler warning.
> > 
> > So split the initrd logic into a separate function, allowing us to
> > declare prop only when we need it.
> > 
> > Built for both cases and booted with an initrd.
> > 
> > Signed-off-by: Michael Ellerman <michael at ellerman.id.au>
> > ---
> > 
> >  arch/powerpc/kernel/prom.c |   48 ++++++++++++++++++++++++++++++---------------
> >  1 file changed, 32 insertions(+), 16 deletions(-)
> > 
> > Index: powerpc/arch/powerpc/kernel/prom.c
> > ===================================================================
> > --- powerpc.orig/arch/powerpc/kernel/prom.c
> > +++ powerpc/arch/powerpc/kernel/prom.c
> > @@ -716,11 +716,41 @@ static int __init early_init_dt_scan_cpu
> >  	return 0;
> >  }
> >  
> > +#ifdef CONFIG_BLK_DEV_INITRD
> 
> > +#else
> > +static inline void early_init_dt_check_for_initrd(unsigned long node)
> > +{
> > +	return;
> > +}
> > +#endif /* CONFIG_BLK_DEV_INITRD */
> 
> There's no need to use `return' in functions returning void.

I think it looks nicer :)

cheers

-- 
Michael Ellerman
OzLabs, IBM Australia Development Lab

wwweb: http://michael.ellerman.id.au
phone: +61 2 6212 1183 (tie line 70 21183)

We do not inherit the earth from our ancestors,
we borrow it from our children. - S.M.A.R.T Person
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://lists.ozlabs.org/pipermail/linuxppc-dev/attachments/20070510/8e1abcac/attachment.pgp>


More information about the Linuxppc-dev mailing list