[RFC] powerpc: Document new property called interrupt-parents

Segher Boessenkool segher at kernel.crashing.org
Wed Feb 28 10:40:31 EST 2007


> +For devices that generate interrupts to multiple interrupt
> +controllers, the  interrupt-parent representation
> +is not sufficient because it only describes a single
> +interrupt parent. The 'interrupt-parents' property should be used
> +to represent this (note the plural in the property name).

s/should be used/can be used/

> +   pic0: pic at 700 {
> +       interrupt-controller;
> +       #address-cells = <0>;
> +       #interrupt-cells = <2>;
> +       reg = <700 100>;
> +       device_type = "open-pic";
> +   };

I still say the #address-cells should be removed.

> +   ethernet at 25000 {
> +       #address-cells = <1>;
> +       #size-cells = <0>;
> +       device_type = "network";
> +       model = "fsl,TSEC";
> +       compatible = "gianfar";
> +       reg = <25000 1000>;
> +       mac-address = [ 00 E0 0C 00 73 01 ];
> +       interrupt-parents = <&pic0 &pic0 &pic1>;
> +       interrupts = <13 3 14 3 18 3>;
> +       phy-handle = <2452001>;
> +   };

Maybe write this like

ethernet at 25000 {
         device_type = "network";
         reg = <25000 1000>;
         ...
         interrupt-parents = <&pic0 &pic0 &pic1>;
         interrupts = <13 3 14 3 18 3>;
};

to make the example more readable?  And some spacing in
the properties, so maybe

ethernet at 25000 {
         device_type = "network";
         reg = <25000 1000>;
         ...
         interrupt-parents = <&pic0 &pic0 &pic1>;
         interrupts        = <13 3  14 3  18 3 >;
};

> +Note: each interrupt parent in the interrupt-parents array can
> +potentially specify a different value for #interrupt-cells.  The 
> number
> +of #interrupt-cells for each parent must be determined to correctly
> +parser the interrupts property.

s/parser/parse/


Segher




More information about the Linuxppc-dev mailing list