[PATCH 2/3] spufs: fix another off-by-one bug in mbox_read

Arnd Bergmann arnd at arndb.de
Wed Oct 25 05:07:43 EST 2006


On Tuesday 24 October 2006 20:42, Pekka Enberg wrote:
> On 10/24/06, Arnd Bergmann <arnd at arndb.de> wrote:
> >         spu_acquire(ctx);
> > -       for (count = 0; count <= len; count += 4, udata++) {
> > +       for (count = 0; (count + 4) <= len; count += 4, udata++) {
>
> Wouldn't this be more obvious as
>
>   for (count = 0, count < (len / 4); count++, udata++) {
>
> And then do count * 4 if you need the actual index somewhere. Hmm?

Count is the return value from a write() file operation. I find it
more readable to update that every time I do one put_user(), to
the exact value, than calculating the return code later.

	Arnd <>< 



More information about the Linuxppc-dev mailing list