Problem of "Connecting to BDI loader failed (-1201)"

Zhou Rui vancasperz at
Wed Oct 4 23:33:17 EST 2006

I am a newbie for BDI2000. Today I tried to setup BDI2000 for PPC405EP PPChameleonEVB board. I did the initial setup based on the manual:
1. make (to compile the executable "bdisetup")
2. ./bdisetup -u -p/dev/ttyS0 -b57 -aGDB -tPPC400
3. ./bdisetup -c -p/dev/ttyS0 -b57 -i192.168.1.123 -h192.168.1.104 -m255.255.255.0 -g192.168.1.239 -foctobus.cfg
4. ./bdisetup -v -p/dev/ttyS0 -b57 -s
5. telnet
Then the telnet ran well. But after I quitted from telnet and tried to run "./bdisetup -v -p/dev/ttyS0 -b57", I got "Connecting to BDI loader failed (-1201)Connecting to BDI loader failed (-1201)". And I got the same results when I tried others parameters such as -u, -c, -e. So would anyone give me some advice about this? Thanks a lot.

Best wishes

Zhou Rui
Distributed & Embedded System Lab
School of Information Science & Engineering
Lanzhou University, P. R. China
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Linuxppc-dev mailing list