[FYI] linux 2.6 still not working with PReP (ppc32)

Sebastian Heutling sheutlin at gmx.de
Tue Jan 11 02:19:03 EST 2005

On Mon, 2005-01-10 at 07:34 +0100, Sven Luther wrote:


> > I also tried the 2.6.10 and found out that it doesn't work here as well. 
> > First I get a lot of lost interrupts from the IDE driver and after that 
> > I also get the SCSI timeouts. It must have something to do with the prep 
> > changes in 2.6.9. One difference in IRQ setup I noticed is in 
> > prep_pcibios_fixup(). If I remember correctly before 2.6.9 at least on 
> > this Utah machine the IRQs are assigned from Motherboard_routes[] 
> > without doing anything else. Now additionally the IRQ is also written 
> > into the devices pci config space which might not work on the 
> > PowerstackII Utah.
> > It's only a guess and I haven't had the time yet to test it.
> Can you try the debian kernels i upload and fill bugreports against them ?

I tried the 2.6.9 kernel. Same problem as in 2.6.10. I hacked a little
in prep_pci.c/prep_pcibios_fixup() but nothing. Then I replaced
prep_pci.c and prep_setup.c by using the 2.6.8 ones to be sure that this
problem isn't coming from elsewhere and guess what: It worked again. So
something from 2.6.8 to 2.6.9 in those two files must be causing this
IRQ problem.


More information about the Linuxppc-dev mailing list