[FYI] linux 2.6 still not working with PReP (ppc32)

Sven Luther sven.luther at wanadoo.fr
Fri Jan 7 08:49:27 EST 2005

On Thu, Jan 06, 2005 at 10:21:04PM +0100, Christian wrote:
> On Thu, January 6, 2005 22:07, Sven Luther said:
> >>
> >> no disks attached, but i will do some more tests on this tonight...
> >
> > Ah, no wonder you don't see a disk then ...
> ;-)
> > I wonder if d-i is upto installing a NFS-root system, i don't think so.
> yes, i can see that. nfsroot is my only way to go here. (will probably get
> a proper scsi-cable soon)

If your NFS server is also powerpc, you could just debootstrap the partition
there :) I guess pure NFS support will have to wait for sarge+1. Now that d-i
is branched, patches are welcome though.

> > See :
> >   http://svn.debian.org/wsvn/kernel/trunk/kernel/source/kernel-source-2.6.8-2.6.8/debian/patches/powerpc-prep-powerstack-irq.dpatch?op=file&rev=0&sc=0
> ah, ok. will try.

I just moved it to 2.6.9, but these kernel-source are not yet released, and
probably won't be until this WE or something, at which point the official
powerpc kernels will include it. With a bit of luck we will have real prep
support in d-i two weeks from now, depending how i am able to fix the
partman-prep horror story. (Added bunch of logs -> it worked, removed them ->
don't work anymore, altough it works on power4 chrp hardware :/)


Sven Luther

More information about the Linuxppc-dev mailing list