[FYI] linux 2.6 still not working with PReP (ppc32)

Sebastian Heutling sheutlin at gmx.de
Wed Jan 5 01:42:54 EST 2005

On Tue, 2005-01-04 at 15:04 +0100, Marc Dietrich wrote:
> Hallo Sebastian,
> Am Dienstag, 4. Januar 2005 12:31 schrieben Sie:
> > Hello Marc,
> >
> > Marc Dietrich wrote:
> > >Hi Christian,
> >
> > Erm ... I'm Sebastian ;-)
> ah! - sorry Sebastian, to many confusion in the last time...

Hehe :)

> > I am using a 2.6.8 (I was too lazy to patch & compile a 2.6.9 and wanted
> > to test 2.6.10 when it's (the sources) in debian/unstable).
> >
> > >Can you put a working zImage.prep somewhere on the web (<1.44 MB, so I can
> > >write it to a floppy disk)?
> >
> > I will do that and tell you later where you can download it.
> This may no longer be necessary, but see below.
> Acording to your log, your scsi drive also fails later, but boots from ide 
> (how did you managed to install the ide disks?).

Yep, it fails later but it doesn't boot from IDE. The SCSI disk is
recognized correctly and the system is on the SCSI drive. The IDE disks
only contain data. It fails later that is right but it still works after
Making IDE work was easy. A friend soldered the connectors and then I
passed "ide0=ide0=0x1f0,0x3f6,14" as kernel parameter to make channel 0
work. Later on after, discovering what was wrong with 2.6 kernels, I
enabled the correct interrupt in the appropriate table in prep_pci.c.

> I posted a message to linux-scsi describing this problem. I guess the sym2 
> driver never worked on the PReP machines. I tried it also with 2.4 kernels. 
> So to summerize it: No one has a working Powerstack with 2.6 kernel and 
> booting from SCSI. I hope there will be some input from the scsi list.

As said above, it does really work although I have to admit there is a
problem with PCI or IRQ handling in general. You can also see in my log
that one of the ethernet devices has problems every now and then. All in
all it is sort of functional.
You can also try to remove every additional PCI device except the gfx
card and see what happens. I had to remove an additional SCSI host
controller in order to avoid problems with other PCI devices (mostly it
was one of the ethernet devices which lost an interrupt).
But I share your thoughts that there is something wrong with the sym2

> > >How does your boot.log looks like?
> >
> > Attached it.
> > Note that I use a Matrox MilleniumII gfx card and XFree4 runs fine
> > (without any crash) since I got a 2.6 kernel running (although I am not
> > using XFree because I use the Powerstack as a router/server which has no
> > Monitor).
> Yeah - I search so many times for a Millenium card on eBay. Now I got one for 
> EUR 1.00 but  it is in Germany, while I'm in France now for holidays :-(
> I also have a P9100 here, but it is not supported (yet?) under linux...



More information about the Linuxppc-dev mailing list