TEST: Sleep suppport for iBook G4 & Aluminium PowerBooks (ATI based)

Benjamin Herrenschmidt benh at kernel.crashing.org
Sun Nov 21 09:52:26 EST 2004

On Sat, 2004-11-20 at 22:41 +0000, Sean Neakums wrote:

> It was built modular but not loaded, and /dev/apm_bios was present.
> Having exited X, loaded the module and restarted X, I tried
> suspend/resume again.  It worked well as before, but the corruption is
> still present.  In XFree86.0.log, I now see a "(II) Open APM
> successful" instead of "(WW) Open APM failed (/dev/apm_bios) (No such
> device) ", but nothing that seems to relate to suspend/resume events.
> The corruption doesn't appear immediately; it starts as a light
> specking of the image and progressively getting worse with subsequent
> redisplayings.

No idea at this point. It doesn't happen on the albooks I could test
with here... Can you send me a snapshot of a corrupted screen ? Does
it still happen if you disable dynamic clocks ?
(radeonfb.default_dynclk=-1 on the kernel cmdline and Option
"DynamicClocks" "false" in X if you are using X.org). And if you disable
accel in X ? (Option "NoAccel" "true")


More information about the Linuxppc-dev mailing list