Cardbus issues on TiBook

Marcus O.C. Metzler mocm at
Fri Sep 7 09:01:41 EST 2001

Ira Weiny writes:
 > As some of you may know I am trying to get an IBM microdrive working on
 > my TiBook.  I know there is an issue with irq's which I am trying to
 > work out but I have run into another issue I don't understand.
 > I get the following message in my startup:
 > kernel: Can't get bus-range for /pci at f2000000/cardbus at 1a
 > I rsync'ed with Ben H's kernel recently and I found that the ioports and
 > memory ranges I had set for cardmgr were not working anymore.  So I
 > started changing them.  In my efforts to find ranges that worked I found
 > that "cat /proc/ioports" would result in a segfault.  From what I can
 > tell it is running off the end of the buffer in vsnprintf?
 > Before the Cardbus modules are loaded "cat /proc/ioports" works fine.
 > So my question is, what does the above message mean?  It is something
 > which is worked around later, or could it be the root of my problem?
 > Thanks,
 > Ira Weiny
 > iweiny at
I use the following in /etc/pcmcia/config.opts

include port 0x0fff-0x1fff
include memory 0x90000000-0x90ffffff

AFAIR it worked with my microdrive, but I don't have it to test right


Dr. Marcus Metzler
mocm at           
mocm at          

Convergence Integrated Media GmbH
Rosenthaler Str. 51
D-10178 Berlin

** Sent via the linuxppc-dev mail list. See

More information about the Linuxppc-dev mailing list