Cardbus issues on TiBook

Ira Weiny iweiny at
Fri Sep 7 06:19:36 EST 2001

As some of you may know I am trying to get an IBM microdrive working on
my TiBook.  I know there is an issue with irq's which I am trying to
work out but I have run into another issue I don't understand.

I get the following message in my startup:

kernel: Can't get bus-range for /pci at f2000000/cardbus at 1a

I rsync'ed with Ben H's kernel recently and I found that the ioports and
memory ranges I had set for cardmgr were not working anymore.  So I
started changing them.  In my efforts to find ranges that worked I found
that "cat /proc/ioports" would result in a segfault.  From what I can
tell it is running off the end of the buffer in vsnprintf?

Before the Cardbus modules are loaded "cat /proc/ioports" works fine.

So my question is, what does the above message mean?  It is something
which is worked around later, or could it be the root of my problem?

Ira Weiny
iweiny at

** Sent via the linuxppc-dev mail list. See

More information about the Linuxppc-dev mailing list