Tom Gall tom_gall at
Thu Nov 29 09:29:18 EST 2001

Troy Benjegerdes wrote:
> On Thu, Nov 29, 2001 at 09:07:12AM +1100, Paul Mackerras wrote:
> >
> > I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
> > linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
> > use that).
> >
> > Does anyone object to this?
> I thought were were goign to call it 'CONFIG_WORKSTATION_PPC' or

Hmmm But doesn't that suggest there is CONFIG_PPC_SERVER? Ick!

Not to ask a stupid question, but what is this CONFIG_ALL_PPC replacement trying
to accomplish?

CONFIG_PPC_PREP seems to imply the PREP standard for all it's warts

CONFIG_PPC_CHRP same thing... tho to me a PMAC and a CHRP box are well, sorta
the same thing

I hate to advocate this but if CONFIG_ALL_PPC isn't really being "truthful" as
far as what it is, then perhaps testing for something like CONFIG_PPC_PREP,
CONFIG_PPC_CHRP etc maybe isn't a bad idea. Code bloat true and certainly a
little harder on the eyes, but it is certainly alot more clear as far as the
expectations the affected portion of code might have.



Tom Gall - [embedded] [PPC64 | PPC32] Code Monkey
Peace, Love &                  "Where's the ka-boom? There was
Linux Technology Center         supposed to be an earth   shattering ka-boom!"
(w) tom_gall at       -- Marvin Martian
(w) 507-253-4558
(h) tgall at

** Sent via the linuxppc-dev mail list. See

More information about the Linuxppc-dev mailing list