Trouble w/yaboot

Ethan Benson erbenson at
Mon Apr 24 17:52:43 EST 2000

On Sun, Apr 23, 2000 at 11:37:33PM -0700, W. Taylor Holliday wrote:
> hi again :-)
> I have an AGP G4 and I'm having trouble getting yaboot to work (I realize
> this is nothing new). I've tried various OF device aliases and none will
> work except cd: (using the linuxPPC installer CD). Both hd: and ultra0: do
> not work (I'm using the partition number w/the kernel on it - doubt there's
> any mistake there); yaboot says the device could not be found. I've even
> tried using the zip: alias and a zip disk with my kernel on it to no avail.
> Any suggestions?

exactly what command are you using to boot yaboot? are you using the
internel IDE disk?  scsi disks do not have device aliases (at least
not that i have seen)

is it OpenFirmare or yaboot that is claiming device not found?
(yaboot turns the screen black) 

the hd: alias SHOULD work

boot hd:6,yaboot  if partition 6 is the one with yaboot on it...

as for your previous message it seems you figured out the answer
yourself: don't use BootX, use yaboot ;-)

Ethan Benson
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 240 bytes
Desc: not available
URL: <>

More information about the Linuxppc-dev mailing list