Setting up yaboot

Ethan Benson erbenson at
Thu Apr 6 22:34:50 EST 2000

On Thu, Apr 06, 2000 at 01:37:06PM +0200, Olaf Hering wrote:
> This is exactly the question I had now, so it seems we all have to
> update the os-chooser script and add PowerBook3,1 to it.

yup, ben made be aware of this recently..  it might be possible to do
away with that part altogether but that would mean alot of testing,
that i can't really do. 

> I will update the suseboot.hqx today, it includes more funny AppleScript
> files for automate the setup process. SCSI Booting is still an issue,
> the only way is to boot directly into yaboot. It works here on many
> differnt machines. 
> Why should ELF loading not work?

elf booting works so long as you don't try to call the yaboot file by
its type (hd:,\\:tbxi) for some bizzare reason OF barfs if a tbxi file
is not a CHRP script.  just for kicks go open a MacOSROM file in a
text editor to see how they worked around this.  (about 80 lines of
nasty Forth code)

> boot hd:9,\\yaboot in the os-chooser script should be the same like
> hd:9,\\yaboot in boot-device for the OF.

yup, but the fact is people hate screwing with OF, so if i use a CHRP
wrapper they should be able to zap OF to its default settings and
still have it automagically boot into the yaboot menu.  (if they
followed my recommendations for how to setup the bootstrap partition)

your failure occured when OF tried to load the CHRP script, not
yaboot. i would think it would output a less obfuscated error then
that if the COMPATIBLE tag was wrong...

> Yes, there is macboot on newer machine, I had no problems so far.

mac-boot works the same as boot, the only difference is it searches
for bootable partitions like the old hardware ROMs did.  but it trys
to load blah:,\\:tbxi 

Ethan Benson
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 240 bytes
Desc: not available
URL: <>

More information about the Linuxppc-dev mailing list