[linux-fbdev] Re: readl() and friends and eieio on PPC
Jes.Sorensen at cern.ch
Mon Aug 16 17:11:19 EST 1999
>>>>> "Paul" == Paul Mackerras <paulus at cs.anu.edu.au> writes:
Paul> Jes Sorensen <Jes.Sorensen at cern.ch> wrote:
>> Defininf a C function with the name of a PPC specific assembler
>> function is pretty stupid. To the best of my knowledge wmb() is the
>> generic name for the thing you are looking for.
Paul> Not exactly, in fact iobarrier() is probably better.
Probably right, as long as it is made clear that iobarrier() means
memory mapped I/O and not I/O mapped I/O. The name is easy to
Other than that I agree, question is whether we need to add more
functions - it seems we are already overly confused.
[[ This message was sent via the linuxppc-dev mailing list. Replies are ]]
[[ not forced back to the list, so be sure to Cc linuxppc-dev if your ]]
[[ reply is of general interest. Please check http://lists.linuxppc.org/ ]]
[[ and http://www.linuxppc.org/ for useful information before posting. ]]
More information about the Linuxppc-dev