ggi and frame buffer

Kostas Gewrgiou gewrgiou at
Wed Apr 14 17:54:33 EST 1999

I just grabbed the source rpms and build them, 
works fine under X (XFree86- dga seems to have some problems though
console works fine also (some times resolution change gives invalide scan 

All this under R4 (most rpms are upgraded to near R5 versions)

  Kostas Gewrgiou

On Tue, 13 Apr 1999, satadru pramanik wrote:

> I'm specifically looking to see if anybody has it working under the
> console.
> On Tue, 13 Apr 1999, Niels Roest wrote:
> On Mon, 12 Apr 1999, satadru pramanik wrote:
> > 
> > Since linuxppc defaults to using a FB-device, ggi should work, right?  So
> > I compiled the latest snapshit, and when I tried to run a demo, ie
> > "cube3d" I got this:
> > cube3d: error in loading shared libraries: /usr/local/lib/
> > R_PPC_REL2
> > 4 relocation out of range
> > 
> > Any clues to what this is?  Has anybody gotten libgii and libggi to work
> > successfully on LinuxPPC, especially pre-rel5?
> > 
> > 
> I did compile it on pre-rel5, the one with libc-2.0.108, and kernel 2.2.1,
> on an 7600 (that's with a control chip if that matters)
> It was a while ago, I rm-ed the sources, but I tried
> it on linux-heretic (I compiled both xheretic and ggiheretic)
> and it still works ok. Note: this is not on console, but in X.
> I didn't try it in console. so ggi on X works.
> Niels
> ----
> satadru pramanik `satadru at'
> "Put your hand on a hot stove for a minute, and it seems like an hour. Sit
> with a pretty girl for an hour, and it seems like a minute. THAT'S
> relativity." 
> -Albert Einstein
> ---

[[ This message was sent via the linuxppc-dev mailing list.  Replies are ]]
[[ not  forced  back  to the list, so be sure to Cc linuxppc-dev if your ]]
[[ reply is of general interest. Please check ]]
[[ and for useful information before posting.   ]]

More information about the Linuxppc-dev mailing list