Bug in LinuxThreads?

Kevin B. Hendricks kbhend at business.wm.edu
Fri Apr 2 04:57:32 EST 1999


I ran your test program under R4.1 and with the very latest glibc 1.99 rpm from
Gary Thomas and it worked fine. (exited properly)

By the way, your comment in the code about how to compile is wrong (it is
libpthread.so NOT libpthreads.so) so -lpthread no -lpthreads

I have made a few changes to linuxthreads to improve performance with the JDK
1.2 native threads.  Please try with Gary's latest glibc 1.99 rpm (which has
libpthread in it).  It that doesn't work, I will post my libpthread.so and
libpthread.a for you to try.

If only my version works for you, I will post the diffs for you and you can roll
your own.

I hope this helps.


[[ This message was sent via the linuxppc-dev mailing list.  Replies are ]]
[[ not  forced  back  to the list, so be sure to Cc linuxppc-dev if your ]]
[[ reply is of general interest. Please check http://lists.linuxppc.org/ ]]
[[ and http://www.linuxppc.org/ for useful information before posting.   ]]

More information about the Linuxppc-dev mailing list