[PATCH v2 02/22] mtd: spi-nor: Introduce 'struct spi_nor_controller_ops'
Tudor.Ambarus at microchip.com
Tudor.Ambarus at microchip.com
Thu Oct 24 08:24:57 AEDT 2019
On 09/24/2019 10:45 AM, Tudor Ambarus - M18064 wrote:
> From: Tudor Ambarus <tudor.ambarus at microchip.com>
>
> Move all SPI NOR controller driver specific ops in a dedicated
> structure. 'struct spi_nor' becomes lighter.
>
> Use size_t for lengths in 'int (*write_reg)()' and 'int (*read_reg)()'.
> Rename wite/read_buf to buf, the name of the functions are
> suggestive enough. Constify buf in int (*write_reg). Comply with these
> changes in the SPI NOR controller drivers.
>
> Suggested-by: Boris Brezillon <boris.brezillon at collabora.com>
> Signed-off-by: Tudor Ambarus <tudor.ambarus at microchip.com>
> ---
> drivers/mtd/spi-nor/aspeed-smc.c | 23 ++++++-----
> drivers/mtd/spi-nor/cadence-quadspi.c | 39 ++++++++++--------
> drivers/mtd/spi-nor/hisi-sfc.c | 22 +++++-----
> drivers/mtd/spi-nor/intel-spi.c | 24 ++++++-----
> drivers/mtd/spi-nor/mtk-quadspi.c | 25 +++++++-----
> drivers/mtd/spi-nor/nxp-spifi.c | 23 +++++++----
> drivers/mtd/spi-nor/spi-nor.c | 76 ++++++++++++++++++++---------------
> include/linux/mtd/spi-nor.h | 51 +++++++++++++----------
> 8 files changed, 166 insertions(+), 117 deletions(-)
Applied to spi-nor/next.
More information about the Linux-aspeed
mailing list