[PATCH v2 1/2] gpio: Add definition for GPIO direction

Linus Walleij linus.walleij at linaro.org
Thu Nov 7 19:20:15 AEDT 2019

On Wed, Nov 6, 2019 at 9:51 AM Matti Vaittinen
<matti.vaittinen at fi.rohmeurope.com> wrote:

> At least for me it is difficult to remember the meaning of GPIO
> direction values. Define GPIO_LINE_DIRECTION_IN and
> GPIO_LINE_DIRECTION_OUT so that occasional GPIO contributors would
> not need to always check the meaning of hard coded values 1 and 0.
> Signed-off-by: Matti Vaittinen <matti.vaittinen at fi.rohmeurope.com>

Patch applied.

Linus Walleij

More information about the Linux-aspeed mailing list