[PATCH -next] mmc: aspeed: Fix return value check in aspeed_sdc_probe()
ulf.hansson at linaro.org
Tue Aug 27 23:49:43 AEST 2019
On Tue, 27 Aug 2019 at 02:47, Julia Lawall <julia.lawall at lip6.fr> wrote:
> On Tue, 27 Aug 2019, Andrew Jeffery wrote:
> > On Mon, 26 Aug 2019, at 22:34, Dan Carpenter wrote:
> > > > Fixes: 09eed7fffd33 ("mmc: Add support for the ASPEED SD controller")
> > > ^^^^
> > > When we're adding new files, could we use the prefix for the new driver
> > > instead of just the subsystem? "mmc: aspeed: Add new driver"?
> > > Otherwise it's tricky to know what people want for the driver.
> > I don't have any issue with the request, but I don't understand this last
> > bit. What do you mean by "it's tricky to know what people want for the
> > driver"?
> There is no obvious algorithm that tells how to go from a file name to an
> appropriate subject line prefix.
For MMC we normally use the name of the host driver file (excluding
".c") as part of the prefix.
For this case that means I amended the header into: mmc:
sdhci-of-aspeed: Fix return value check in aspeed_sdc_probe() and
applied it for next.
I also took the liberty to change this for the other related patches
for the "aspeed" driver to follow the same pattern.
More information about the Linux-aspeed