[Lguest] [PATCH 0309/1285] Replace numeric parameter like 0444 with macro

Rusty Russell rusty at rustcorp.com.au
Wed Aug 3 12:37:19 AEST 2016


Baole Ni <baolex.ni at intel.com> writes:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.

I find the numbers far, far more readable.

Cheers,
Rusty.

>  /* Allow Guests to use a non-128 (ie. non-Linux) syscall trap. */
>  static unsigned int syscall_vector = IA32_SYSCALL_VECTOR;
> -module_param(syscall_vector, uint, 0444);
> +module_param(syscall_vector, uint, S_IRUSR | S_IRGRP | S_IROTH);
>  
>  /* The address of the interrupt handler is split into two bits: */
>  static unsigned long idt_address(u32 lo, u32 hi)
> -- 
> 2.9.2


More information about the Lguest mailing list