[PATCH 2/3] ARM: OMAP2+: rename gpmc_probe_nor_child() to gpmc_probe_generic_child()
Jon Hunter
jon-hunter at ti.com
Fri Mar 15 05:51:23 EST 2013
On 03/14/2013 10:09 AM, Javier Martinez Canillas wrote:
> The gpmc_probe_nor_child() function is used in the GPMC driver to
> configure the GPMC for a NOR child device node.
>
> But this function is quite generic and all the NOR specific configuration
> is made by the driver of the actual NOR flash memory used.
>
> Other Pseudo-SRAM devices such as ethernet controllers need a similar
> setup so by making this function generic it can be used for those too.
>
> Signed-off-by: Javier Martinez Canillas <javier.martinez at collabora.co.uk>
> ---
> arch/arm/mach-omap2/gpmc.c | 10 +++++-----
> 1 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/arch/arm/mach-omap2/gpmc.c b/arch/arm/mach-omap2/gpmc.c
> index 8799aed..898b44d 100644
> --- a/arch/arm/mach-omap2/gpmc.c
> +++ b/arch/arm/mach-omap2/gpmc.c
> @@ -1439,14 +1439,14 @@ static int gpmc_probe_onenand_child(struct platform_device *pdev,
> #endif
>
> /**
> - * gpmc_probe_nor_child - configures the gpmc for a nor device
> + * gpmc_probe_generic_child - configures the gpmc for a child device
> * @pdev: pointer to gpmc platform device
> - * @child: pointer to device-tree node for nor device
> + * @child: pointer to device-tree node for child device
> *
> - * Allocates and configures a GPMC chip-select for a NOR flash device.
> + * Allocates and configures a GPMC chip-select for a child device.
> * Returns 0 on success and appropriate negative error code on failure.
> */
> -static int gpmc_probe_nor_child(struct platform_device *pdev,
> +static int gpmc_probe_generic_child(struct platform_device *pdev,
> struct device_node *child)
> {
> struct gpmc_settings gpmc_s;
> @@ -1552,7 +1552,7 @@ static int gpmc_probe_dt(struct platform_device *pdev)
> }
>
> for_each_node_by_name(child, "nor") {
> - ret = gpmc_probe_nor_child(pdev, child);
> + ret = gpmc_probe_generic_child(pdev, child);
> if (ret < 0) {
> of_node_put(child);
> return ret;
>
Thanks, looks good. I will pick this up too.
Cheers
Jon
More information about the devicetree-discuss
mailing list