[PATCH v4 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child
Srinivas KANDAGATLA
srinivas.kandagatla at st.com
Tue Sep 18 17:10:36 EST 2012
From: Srinivas Kandagatla <srinivas.kandagatla at st.com>
As follow-up to "dt: introduce of_get_child_by_name to get child node by
name." patch, This patch removes some of the code duplication in the
driver by replacing it with of_get_child_by_name instead.
Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla at st.com>
---
arch/powerpc/platforms/powernv/opal.c | 6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/powerpc/platforms/powernv/opal.c b/arch/powerpc/platforms/powernv/opal.c
index aaa0dba..f4a5567 100644
--- a/arch/powerpc/platforms/powernv/opal.c
+++ b/arch/powerpc/platforms/powernv/opal.c
@@ -294,10 +294,10 @@ static int __init opal_init(void)
consoles = of_node_get(opal_node);
/* Register serial ports */
- for_each_child_of_node(consoles, np) {
- if (strcmp(np->name, "serial"))
- continue;
+ np = of_get_child_by_name(consoles, "serial");
+ if (np) {
of_platform_device_create(np, NULL, NULL);
+ of_node_put(np);
}
of_node_put(consoles);
--
1.7.0.4
More information about the devicetree-discuss
mailing list