[PATCH v7 2/8] of: add helper to parse display timings
Thierry Reding
thierry.reding at avionic-design.de
Fri Nov 2 07:15:10 EST 2012
On Wed, Oct 31, 2012 at 10:28:02AM +0100, Steffen Trumtrar wrote:
[...]
> diff --git a/Documentation/devicetree/bindings/video/display-timings.txt b/Documentation/devicetree/bindings/video/display-timings.txt
[...]
> @@ -0,0 +1,139 @@
> +display-timings bindings
> +==================
> +
> +display-timings-node
> +------------
Maybe extend the underline to the length of the section and subsection
titles respectively?
> +struct display_timing
> +===================
Same here.
> +config OF_DISPLAY_TIMINGS
> + def_bool y
> + depends on DISPLAY_TIMING
Maybe this should be called OF_DISPLAY_TIMING to match DISPLAY_TIMING,
or rename DISPLAY_TIMING to DISPLAY_TIMINGS for the sake of consistency?
> +/**
> + * of_get_display_timing_list - parse all display_timing entries from a device_node
> + * @np: device_node with the subnodes
> + **/
> +struct display_timings *of_get_display_timing_list(struct device_node *np)
Perhaps this would better be named of_get_display_timings() to match the
return type?
> + disp = kzalloc(sizeof(*disp), GFP_KERNEL);
Shouldn't you be checking this for allocation failures?
> + disp->timings = kzalloc(sizeof(struct display_timing *)*disp->num_timings,
> + GFP_KERNEL);
Same here.
Thierry
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <http://lists.ozlabs.org/pipermail/devicetree-discuss/attachments/20121101/a8c7eb33/attachment.sig>
More information about the devicetree-discuss
mailing list