[PATCH] sparc: move is_root_node from private header to of.h

Andres Salomon dilinger at queued.net
Wed Jul 14 06:05:41 EST 2010


On Mon, 12 Jul 2010 09:53:04 -0600
Grant Likely <grant.likely at secretlab.ca> wrote:

> On Tue, Jul 13, 2010 at 3:42 AM, Andres Salomon <dilinger at queued.net>
> wrote:
> >
> > Make is_root_node available for all archs to use, as it's not
> > PROM-specific. Also rename it to of_is_root_node, and a few other
> > minor changes for style/consistency.
> >
> > Signed-off-by: Andres Salomon <dilinger at queued.net>
> > ---
> >  arch/sparc/kernel/prom.h        |    8 --------
> >  arch/sparc/kernel/prom_64.c     |    6 +++---
> >  arch/sparc/kernel/prom_common.c |    2 +-
> >  include/linux/of.h              |    8 ++++++++
> >  4 files changed, 12 insertions(+), 12 deletions(-)
> [...]
> > diff --git a/include/linux/of.h b/include/linux/of.h
> > index a367e19..b38cdf7 100644
> > --- a/include/linux/of.h
> > +++ b/include/linux/of.h
> > @@ -97,6 +97,14 @@ extern struct device_node *of_node_get(struct
> > device_node *node); extern void of_node_put(struct device_node
> > *node); #endif
> >
> > +static inline bool of_is_root_node(const struct device_node *node)
> > +{
> > +       if (!node)
> > +               return false;
> > +
> > +       return (node->parent == NULL);
> > +}
> 
> Are you okay if I shorten this to?
> 
> +static inline bool of_is_root_node(const struct device_node *node)
> +{
> +       return (node && (node->parent == NULL));
> +}
> 
> g.

It's fine with me.



More information about the devicetree-discuss mailing list