[ccan] CCAN News for February / March
Rusty Russell
rusty at rustcorp.com.au
Tue Apr 5 17:29:52 EST 2011
Hi all!
Fixes all over the place in the last two months, and I've been
getting more feedback from coders (much offlist, unfortunately!) which
has lead to portability improvements in many places.
My favorite new module this month is cast: a set of C++-inspired
macros for specifying (and checking!) that specify exactly what you're
casting away. Inspired by Jan Engelhardt's libhx.
New Modules:
asprintf: asprintf wrapper (and if necessary, implementation).
cast: routines for safer casting
daemon-with-notify: daemonize a process, can wait for child to signal readiness
Changed modules:
array: renamed to darray, various improvements
asort: portability improvements from Andreas Schlick
build_assert: rename EXPR_BUILD_ASSERT to BUILD_ASSERT_OR_ZERO
endian: use byteswap.h if available, and use those names.
failtest: major enhancements
foreach: allow single value iteration, minor fixes.
net: minor fixes
opt: warning cleanups, opt_free_table.
str: provide wrappers for isalpha et al, strstr.
tdb2: first alpha release, now usable!
typesafe: now compiles wiht -Wpointer-arith and -Wcast-qual
Infrastructure:
config.h: now defines _GNU_SOURCE so we get asprintf et al.
config.h: add -Wpointer-arith and -Wwrite-strings by default
Standardize on CCAN_<MODNAME>_DEBUG everywhere.
ccanlint: reduced feature test, stringcheck test, misc. improvements.
licenses: add copy of BSD 3-clause.
Minor cleanups
Thanks!
Rusty.
More information about the ccan
mailing list