[Cbe-oss-dev] [PATCH 9/10] spu sched: implement real runqueues

Jeremy Kerr jk at ozlabs.org
Mon Jan 8 10:34:15 EST 2007


> Index: linux-2.6/arch/powerpc/platforms/cell/spufs/sched.c
> ===================================================================
> ---
> linux-2.6.orig/arch/powerpc/platforms/cell/spufs/sched.c	2007-01-07
> 21:53:38.000000000 +0100 +++
> linux-2.6/arch/powerpc/platforms/cell/spufs/sched.c	2007-01-07
> 22:46:42.000000000 +0100 @@ -49,9 +49,10 @@
>  #define SPU_BITMAP_SIZE (((MAX_PRIO+BITS_PER_LONG)/BITS_PER_LONG)+1)
>  struct spu_prio_array {
>  	unsigned long bitmap[SPU_BITMAP_SIZE];
> -	wait_queue_head_t waitq[MAX_PRIO];
> +	struct list_head rq[MAX_PRIO];

Can we call this 'runq' instead?

>  	struct list_head active_list[MAX_NUMNODES];
>  	struct mutex active_mutex[MAX_NUMNODES];
> +	struct mutex mutex;

and this one 'runq_mutex' ? I know it also protects the bitfield, but 
that's really part of the run queue system.


Jeremy



More information about the cbe-oss-dev mailing list