On , Chris Ball <cjb@laptop.org> wrote:<br />> Hi Zhangfei,<br />> <br />> <br />> <br />> On Tue, Jun 12 2012, zhangfei gao wrote:<br />> <br />> > On Wed, Jun 13, 2012 at 3:05 AM, Chris Ball cjb@laptop.org> wrote:<br />> <br />> <br />> How do you feel about having the compatible node say "sdhci-pxav3"<br />> instead of "mrvl,pxav3-mmc"?  I used the mrvl prefix because it fits<br />> in with the rest of your existing DT, but it seems like it would be<br />> better to name the driver directly.  The DTs here live inside the<br />> source tree, so we're not depending on anyone else's terminology.<br />> <br />> If you're okay with sdhci-pxav{2,3} in compatible, I'll include that<br />> in v2 of the patch with the rest of your fixes.<br />> <br />Compatible node could be "mrvl,pxav3-mmc" or "mrvl,sdhci-pxav3". It's <br />depend on your choice. I prefer to use vendor name in compatible property.<br />And we could avoid naming conflict.<br /><br />+       if (of_find_property(np, "non-removable", NULL))<br />+               pdata->flags |= PXA_FLAG_CARD_PERMANENT;<br />+<br />+       of_property_read_u32(np, "bus-width", &bus_width);<br />+       if (bus_width == 8)<br />+               pdata->flags |= PXA_FLAG_SD_8_BIT_CAPABLE_SLOT;<br />+<br />+       of_property_read_u32(np, "clk-delay-cycles", &clk_delay_cycles);<br />+       if (clk_delay_cycles > 0)<br />+               pdata->clk_delay_cycles = clk_delay_cycles;<br />+<br /><br />These properties should be "mrvl,non-removable", "mrvl,bus-width", <br />"mrvl,clk-delay-cycles".  Since it's mentioned in <br />Documentations/devicetree/booting-without-of.txt. "It is recommended <br />that if you add any "custom" property whose name may clash with <br />standard defined ones, you prefix them with your vendor name and <br />a comma."